We might be holding off because we use vShield edge and a third party equivalent of vShield app.  There is still an issue with ESXi hosts PSODS in 5.  Will probably go to 4.1 Update 2 in the mean time.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2007404